AP, PP, AL, LP, TC

в Excel и посмотрите, как будет формироваться кривая вашего капитала.

Для этого необходимо сделать следующее.

1. Открыть таблицу Excel. В ячейки одного столбца вы забиваете формулу ‘=СЛЧИС () ’, которая возвращает случайное число от 0 до 1. Это будет опорный генератор случайных чисел для каждой сделки.

2. В ячейки следующего столбца вы забиваете исход сделки с заданной вероятностью. Чтобы записать условие –200 пунктов с вероятностью 30 % и +200 пунктов с вероятностью 70 %, вы просто указываете: если случайное число из первого столбца > 0,7, то –200, иначе +200. То есть в ячейку второго столбца (B1) запишем: ‘=ЕСЛИ(A1>0,7;–200;200)’.

3. В ячейках третьего столбца мы суммируем результат, складывая итог текущей сделки с предыдущим накопленным результатом.

4. В четвертом столбце можно учесть влияние издержек на результат каждой сделки, а в пятом – просуммировать результат с учетом издержек.

Ваша таблица будет выглядеть примерно так:

Рис. 19.

Таким образом, вы можете посмотреть, насколько жизнеспособна система с заданными параметрами из формулы 2:

• величина среднего тейк-профита (AP);

• вероятность прибыльной сделки (PP);

• величина среднего стоп-лосса (AL);

• издержки на сделку – комиссия и проскальзывание (TC).

Для примера я взял параметры, близкие к системе хорошо известного на «Смартлабе» трейдера Александра Муханчикова, с которыми он, во всяком случае, торговал в первой половине 2014 г. Средний стоп (AL) = средний тейк-профит (TP) = 200 пунктов фьючерса РТС, вероятность прибыльной сделки (PP) 70 %, соответственно, убыточной (LP) = 30 %. Проскальзывание и комиссию возьмем 10 пунктов на одну сделку, то есть 20 пунктов на куплю-продажу. Обозначим такую систему, как

<< | >>
Источник: Тимофей Мартынов. Механизм трейдинга: Как построить бизнес на бирже? Как построить бизнес на бирже. 2016

Еще по теме AP, PP, AL, LP, TC:

  1. Вспомогательная аксиома № 15. Никогда не пытайтесь спасти плохие инвестиции за счет усреднения
  2. Спекулятивная стратегия
  3. Основная аксиома № 12
  4. О планировании
  5. Вспомогательная аксиома № 16. Избегайте долгосрочных инвестиций
  6. Спекулятивная стратегия
  7. Основная аксиома № 11
  8. Об упорстве
  9. Спекулятивная стратегия
  10. Основная аксиома № 10
  11. О консенсусе
  12. Вспомогательная аксиома № 14. Никогда не следуйте чужим прихотям. Часто наилучшее время для покупки наступает тогда, когда никто другой этого не хочет
  13. Спекулятивная стратегия
  14. Основная аксиома № 9
  15. Об оптимизме и пессимизме
  16. Вспомогательная аксиома № 12. Если бы астрология работала, то все астрологи были бы богатыми людьми
  17. Вспомогательная аксиома № 13. Не стоит открещиваться от суеверий. Они могут быть забавными, если занимают положенное им место
  18. Спекулятивная стратегия