1.3.3. Двухиндексные задачи ЛП

Двухиндексные задачи ЛП вводятся и решаются в Excel аналогично одноиндексным задачам. Специфика ввода условия двухиндексной задачи ЛП состоит лишь в удобстве матричного задания переменных задачи и коэффициентов ЦФ.
Рассмотрим решение двухиндексной задачи, суть которой заключается в оптимальной организации транспортных перевозок штучного товара со складов в магазины (табл.1.2). Таблица 1.2 Исходные данные транспортной задачи
Тарифы, руб./шт. 1-й магазин 2-й магазин 3-й магазин Запасы, шт.
1-й склад 2 9 7 25
2-й склад 1 0 5 50
3-й склад 5 4 100 35
4-й склад 2 3 6 75
Потребности, шт. 45 90 50

Целевая функция и ограничения данной задачи имеют вид

(1.5)

Экранные формы, задание переменных, целевой функции, ограничений и граничных условий двухиндексной задачи (1.5) и ее решение представлены на рис.1.15, 1.16, 1.17 и в табл.1.3. Рис.1.15. Экранная форма двухиндексной задачи (1.5) (курсор в целевой ячейке F15) Таблица 1.3 Формулы экранной формы задачи (1.5)

Объект математической модели Выражение в Excel
Переменные задачи C3:E6
Формула в целевой ячейке F15 =СУММПРОИЗВ(C3:E6;C12:E15)
Ограничения по строкам в ячейках F3, F4, F5, F6 =СУММ(C3:E3) =СУММ(C4:E4) =СУММ(C5:E5) =СУММ(C6:E6)
Ограничения по столбцам в ячейках С7, D7, E7 =СУММ(C3:C6) =СУММ(D3:D6) =СУММ(E3:E6)
Суммарные запасы и потребности в ячейках H8, G9 =СУММ(H3:H6) =СУММ(C9:E9)

Рис.1.16. Ограничения и граничные условия задачи (1.5) Рис.1.17. Экранная форма после получения решения задачи (1.5) (курсор в целевой ячейке F15)

<< | >>
Источник: Алесинская Т.В., Сербин В.Д., Катаев А.В.. Учебно-методическое пособие по курсу Экономико-математические методы и модели. Линейное программирование. 2001

Еще по теме 1.3.3. Двухиндексные задачи ЛП:

  1. 5. ЛАБОРАТОРНАЯ РАБОТА №4 “ДВУХИНДЕКСНЫЕ ЗАДАЧИ ЛИНЕЙНОГО ПРОГРАММИРОВАНИЯ. ЗАДАЧА О НАЗНАЧЕНИЯХ”
  2. 7. ЛАБОРАТОРНАЯ РАБОТА №6 “ДВУХИНДЕКСНЫЕ ЗАДАЧИ ЛП. ОПТИМАЛЬНОЕ РАСПРЕДЕЛЕНИЕ ПРОИЗВОДСТВЕННЫХ МОЩНОСТЕЙ”
  3. 4. ЛАБОРАТОРНАЯ РАБОТА №3 “ДВУХИНДЕКСНЫЕ ЗАДАЧИ ЛИНЕЙНОГО ПРОГРАММИРОВАНИЯ. СТАНДАРТНАЯ ТРАНСПОРТНАЯ ЗАДАЧА”
  4. 6. ЛАБОРАТОРНАЯ РАБОТА №5 “ДВУХИНДЕКСНЫЕ ЗАДАЧИ ЛИНЕЙНОГО ПРОГРАММИРОВАНИЯ. ОРГАНИЗАЦИЯ ОПТИМАЛЬНОЙ СИСТЕМЫ СНАБЖЕНИЯ”
  5. Исходные параметры модели двухиндексной общей РЗ
  6. 4.3. ТЕОРЕТИЧЕСКАЯ ЧАСТЬ [1,2,3,4,6,7] 4.3.1. Стандартная модель транспортной задачи (ТЗ) Задача о размещении (транспортная задача) –
  7. Решить задачу: a) установить параметры решения задачи (в окне "Поиск решения"); b) запустить задачу на решение (в окне "Поиск решения"); c) выбрать формат вывода решения (в окне "Результаты поиска решения"). 1.3.1. Одноиндексные задачи ЛП
  8. Ввести условие задачи: a) создать экранную форму для ввода условия задачи
  9. 5.3. ЗАДАЧА О НАЗНАЧЕНИЯХ. ТЕОРЕТИЧЕСКАЯ ЧАСТЬ [1,3,6,7] Задача о назначениях
  10. 1.3.4. Задачи с булевыми переменными
  11. 7.3. ТЕОРЕТИЧЕСКАЯ ЧАСТЬ Общая распределительная задача ЛП
  12. Задачи
  13. Задачи
  14. Задачи